Computer Hacking Forensic Investigator Exam 312-49
Course Outline

™

Hacking Forensic

Computer
INVESTIGATOR

Computer Hacking Forensic Investigator

Course Outline

(Version 9)

1. Module 01 Computer Forensics in Today's World
2. Module 02 Computer Forensics Investigation Process
3. Module 03 Understanding Hard Disks and File Systems
4. Module 04 Data Acquisition and Duplication
5. Module 05 Defeating Anti-forensics Techniques
6. Module 06 Operating System Forensics (Windows, Mac, Linux)
7. Module 07 Network Forensics
8. Module 08 Investigating Web Attacks
9. Module 09 Database Forensics
10. Module 10 Cloud Forensics
11. Module 11 Malware Forensics
12. Module 12 Investigating Email Crimes
13. Module 13 Mobile Forensics
14. Module 14 Forensics Report Writing and Presentation
Page | 1 Computer Hacking Forensic Investigator Copyright © by EG-Gouncil

All Rights Reserved. Reproduction is Strictly Prohibited.




Computer Hacking Forensic Investigator

Course Outline

Exam 312-49

Module 01: Computer Forensics in Today’s World

Page | 2

Understanding Computer Forensics

Why and When Do You Use Computer Forensics?

Cyber Crime (Types of Computer Crimes)

Case Study

Challenges Cyber Crimes Present For Investigators

Cyber Crime Investigation

o

o

(@]

(@]

(@]

Civil versus Criminal Investigation
Case Study: Criminal Case

Case Study: Civil Case
Administrative Investigation

Case Study: Administrative Case

Rules of Forensics Investigation

(@]

Enterprise Theory of Investigation (ETI)

Understanding Digital Evidence

Types of Digital Evidence

Characteristics of Digital Evidence

Role of Digital Evidence

o

Digital Forensics Challenges

Sources of Potential Evidence

Rules of Evidence

o

o

o

Best Evidence Rule
“Hearsay” concept

Federal Rules of Evidence

e Scientific Working Group on Digital Evidence (SWGDE)

Forensics Readiness

©)

Forensics Readiness Planning

Computer Forensics as part of an Incident Response Plan

Need for Forensic Investigator

Roles and Responsibilities of Forensics Investigator

What makes a Good Computer Forensics Investigator?
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= |nvestigative Challenges
o Computer Forensics: Legal Issues
o Computer Forensics: Privacy Issues
= Legal and Privacy Issues
= Code of Ethics

= Accessing Computer Forensics Resources
Back to TOC

Module 02: Computer Forensics Investigation Process
= |mportance of Computer Forensics Process
= Phases Involved in the Computer Forensics Investigation Process
= Pre-investigation Phase
o Setting Up a Computer Forensics Lab
= Planning and Budgeting
= Physical Location and Structural Design Considerations
= Work Area Considerations
= Physical Security Recommendations
= Fire-Suppression Systems
= Evidence Locker Recommendations
= Auditing the Security of a Forensics Lab
= Human Resource Considerations
= Build a Forensics Workstation
= Basic Workstation Requirements in a Forensics Lab
=  Build a Computer Forensics Toolkit
= Forensics Hardware
= Forensics Software (Cont’d)
o Build the Investigation Team
= Forensic Practitioner Certification and Licensing
o Review Policies and Laws
= Forensics Laws
o Establish Quality Assurance Processes

= Quality Assurance Practices in Digital Forensics
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= General Quality Assurance in the Digital Forensic Process
= Quality Assurance Practices: Laboratory Software and Hardware
= Laboratory Accreditation Programs
o Data Destruction Industry Standards
o Risk Assessment
= Risk Assessment Matrix
= |nvestigation Phase
o Investigation Process
= Questions to Ask When a Client Calls the Forensic Investigator
= Checklist to Prepare for a Computer Forensics Investigation
= Notify Decision Makers and Acquire Authorization
o Computer Forensics Investigation Methodology: First Response
= First Responder
e Roles of First Responder
= First Response Basics
= Incident Response: Different Situations
e First Response by System Administrators
e First Response by Non-Forensic Staff
e First Response by Laboratory Forensic Staff
= First Responder Common Mistakes
= Documenting the Electronic Crime Scene
e Photographing the Scene
e Sketching the Scene
e Note Taking Checklist
o Computer Forensics Investigation Methodology: Search and Seizure
= Consent
e Sample of Consent Search Form
e Witness Signatures
e Witness Statement Checklist
=  Conducting Preliminary Interviews

= Planning the Search and Seizure
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e |Initial Search of the Scene
= Warrant for Search and Seizure
e Obtain Search Warrant
e Example of Search Warrant
= Searches Without a Warrant
= Health and Safety Issues
= Securing and Evaluating Electronic Crime Scene: A Checklist
o Computer Forensics Investigation Methodology: Collect the Evidence
= Collect Physical Evidence
e Evidence Collection Form
= Collecting and Preserving Electronic Evidence
= Dealing with Powered On Computers
= Dealing with Powered Off Computers
= Dealing with Networked Computer
= Dealing with Open Files and Startup Files
= QOperating System Shutdown Procedure
=  Computers and Servers
= Preserving Electronic Evidence
= Seizing Portable Computers
= Dealing with Switched On Portable Computers
o Computer Forensics Investigation Methodology: Secure the Evidence
= Evidence Management
=  Chain of Custody
e Simple Format of the Chain of Custody Document
e Chain of Custody Forms

e Chain of Custody on Property Evidence Envelope/Bag and Sign-out
Sheet

= Packaging and Transporting Electronic Evidence
e Evidence Bag Contents List
e Packaging Electronic Evidence

e Exhibit Numbering
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e Transporting Electronic Evidence
= Storing Electronic Evidence
o Computer Forensics Investigation Methodology: Data Acquisition
= Guidelines for Acquiring Evidence
= Duplicate the Data (Imaging)
= Verify Image Integrity

e MDS5 Hash Calculators: HashCalc, MD5 Calculator and
HashMyFiles

= Recover Lost or Deleted Data
e Data Recovery Software

o Computer Forensics Investigation Methodology: Data Analysis

= Data Analysis
= Post-investigation Phase

o Computer Forensics Investigation Methodology: Evidence Assessment
= Evidence Assessment
= Case Assessment
=  Processing Location Assessment
= Collecting Evidence from Social Networks
= Best Practices on how to Behave as an Investigator on Social Media
= Best Practices to Assess the Evidence

o Computer Forensics Investigation Methodology: Documentation and Reporting
= Documentation in Each Phase
= Gather and Organize Information
= Writing the Investigation Report

o Computer Forensics Investigation Methodology: Testify as an Expert Witness
= Expert Witness
= Testifying in the Court Room
= (Closing the Case

= Maintaining Professional Conduct

Back to TOC
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Course Outline

Module 03: Understanding Hard Disks and File Systems

=  Hard Disk Drive Overview

©)

(@]

o

o

Disk Drive Overview

Hard Disk Drive (HDD)
Solid-State Drive (SSD)

Physical Structure of a Hard Disk
Logical Structure of Hard Disk
Types of Hard Disk Interfaces

Hard Disk Interfaces

e ATA
e SCSI
e |IDE/EIDE
e USB

e Fibre Channel

Tracks

e Track Numbering

Sector

e Sector Addressing

e Advanced Format: Sectors
Cluster

e C(Cluster Size

e Slack Space

e Lost Clusters

Bad Sectors

Understanding Bit, Byte, and Nibble
Hard Disk Data Addressing
Data Densities on a Hard Disk
Disk Capacity Calculation

Measuring the Performance of the Hard Disk

= Disk Partitions and Boot Process

o
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Disk Partitions
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©)

©)

o

o

BIOS Parameter Block (BPB)Partitioning utilities
Master Boot Record

e Structure of a Master Boot Record
Globally Unique Identifier (GUID)

e GUID Partition Table (GPT)

What is the Booting Process?
Essential Windows System Files
Windows Boot Process

Identifying GUID Partition Table (GPT)
Analyzing the GPT Header and Entries
GPT Artifacts

Macintosh Boot Process

Linux Boot Process

= Understanding File Systems

©)
©)

(@]
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Understanding File Systems
Types of File Systems
Windows File Systems
e File Allocation Table (FAT)
» FAT File System Layout
» FAT Partition Boot Sector
» FAT Folder Structure
» Directory Entries and Cluster Chains
» Filenames on FAT Volumes
> FAT32
e New Technology File System (NTFS)
» NTFS Architecture
NTFS System Files
NTFS Partition Boot Sector
Cluster Sizes of NTFS Volume
NTFS Master File Table (MFT)
= Metadata Files Stored in the MFT

YV V V V
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o

o

» NTFS Attributes
» NTFS Data Stream
» NTFS Compressed Files
= Setting the Compression State of a Volume
» Encrypting File Systems (EFS)
= Components of EFS
= EFS Attribute
» Sparse Files
Linux File Systems

e Linux File System Architecture

File System Hierarchy Standard (FHS)
e Extensible File System (Ext)
e Second Extensible File System (Ext2)
e Third Extensible File System (Ext3)
e Fourth Extensible File System (Ext4)
Mac OS X File Systems
e HFS vs. HFS Plus
e Hierarchical File System (HFS)
e Hierarchical File System Plus (HFS+)
» HFS Plus Volumes
» HFS Plus Journal
Oracle Solaris 11 File System: ZFS
CD-ROM / DVD File System
Compact Disc File System (CDFS)
Virtual File System (VFS) and Universal Disk Format File System (UDF)

= RAID Storage System

o

o

Levels of RAID Storage System
Host Protected Areas (HPA) and Device Configuration Overlays (DCO)

= File System Analysis

o

o
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File Carving

Image File Analysis: JPEG
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o Image File Analysis: BMP

o Hex View of Popular Image File Formats

o PDF File Analysis

o Word File Analysis

o PPT File Analysis

o Excel File Analysis

o Hex View of Other Popular File Formats
e Video
e Audio

o File System Analysis Using Autopsy

o File System Analysis Using The Sleuth Kit (TSK)

o The Sleuth Kit (TSK): fsstat

o The Sleuth Kit (TSK): istat

o The Sleuth Kit (TSK): fls and img_stat

Back to TOC

Module 04: Data Acquisition and Duplication

= Data Acquisition and Duplication Concepts

o

(0]

o

(0]

o

Understanding Data Acquisition
e Types of Data Acquisition Systems
Live Data Acquisition

Order of Volatility

Common Mistakes in Volatile Data Collection

Volatile Data Collection Methodology

= Static Acquisition

@)
©)

©)
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Static Data Acquisition

Rules of Thumb

Why to Create a Duplicate Image?
Bit Stream Image Vs. Backups
Issues with Data Duplication

Data Acquisition and Duplication Steps
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o Prepare a Chain of Custody Document

Exam 312-49

o Enable Write Protection on the Evidence Media

o Sanitize the Target Media: NIST SP 800-88 Guidelines

o Determine the Data Acquisition Format
o Data Acquisition Methods
o Determine the Best Acquisition Method
o Select the Data Acquisition Tool

e Mandatory Requirements

e Optional Requirements

o Data Acquisition and Duplication Tools: Hardware

o Data Acquisition and Duplication Tools: Software

o Linux Standard Tools
o Acquiring Data on Linux: dd Command

o Acquiring Data on Linux: dcfldd Command

o Acquiring Data on Windows: AccessData FTK Imager

o Acquiring RAID Disks
o Remote Data Acquisition
o Data Acquisition Mistakes
o Plan for Contingency
= Validate Data Acquisitions
o Linux Validation Methods
o Windows Validation Methods

= Acquisition Best Practices

Back to TOC

Module 05: Defeating Anti-forensics Techniques

=  What is Anti-Forensics?
o Goals of Anti-Forensics
= Anti-Forensics techniques

o Data/File Deletion

e What Happens When a File is Deleted in Windows?

Page | 11
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Recycle Bin in Windows

Storage Locations of Recycle Bin in FAT and NTFS Systems
How the Recycle Bin Works

Damaged or Deleted INFO2 File

Damaged Files in Recycle Bin Folder

Damaged Recycle Bin Folder

YV V V VYV V V

File Recovery Tools: Windows

File Recovery in MAC OS X

» File Recovery Tools: MAC

» File Recovery in Linux

Recovering the Deleted Partitions

» Partition Recovery Tools: Active@ Partition Recovery

» Partition Recovery Tools (For Windows, MAC, & Linux all together)

Password Protection

Password Types
Password Cracker and its Working
Password Cracking Techniques
Default Passwords
Using Rainbow Tables to Crack Hashed Passwords
» Tools to Create Rainbow Tables: rtgen and Winrtgen
Microsoft Authentication
» How Hash Passwords Are Stored in Windows SAM?
System Software Password Cracking
Bypassing BIOS Passwords
» Using Manufacturer’s Backdoor Password to Access the BIOS
» Using Password Cracking Software
= CmosPwd
= DaveGrohl
» Resetting the CMOS using the Jumpers or Solder Beads
» Removing CMOS Battery

» Overloading the Keyboard Buffer and Using a Professional Service
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e Tool to Reset Admin Password
» Active@ Password Changer
» Windows Password Recovery Bootdisk
» Windows Password Recovery Lastic
e Application Password Cracking Tools
» Word Password Recovery Tools
» PowerPoint Password Recovery Tools
» Excel Password Recovery Tools
» PDF Password Recovery Tools
» ZIP/RAR Password Recovery Tool: Advanced Archive Password Recovery
» Other Application Software Password Cracking Tools
e Other Password Cracking Tools
Steganography
e Steganography
» Steganography
» Types of Steganography based on Cover Medium
e Steganalysis
» Steganalysis
» Steganalysis Methods/Attacks on Steganography
» Detecting Steganography
» Steganography Detection Tool: Gargoyle Investigator™ Forensic Pro
» Steganography Detection Tools
Data Hiding in File System Structures
Trail Obfuscation
Artifact Wiping
Overwriting Data/Metadata
Encryption
e Encrypting File System (EFS): Recovery Certificate
e Advanced EFS Data Recovery Tool
Encrypted Network Protocols

Program Packers
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o Rootkits

e Detecting Rootkits

e Steps for Detecting Rootkits
o Minimize Footprint
o Exploiting Forensic Tools Bugs
o Detecting Forensic Tool Activities
o Anti-Forensics Countermeasures
o Anti-Forensics Challenges
o Anti-forensics Tools

e Privacy Eraser

e Azazel Rootkit

e QuickCrypto

o Anti-forensics Tools
Back to TOC

Module 06: Operating System Forensics (Windows, Mac, Linux)
Introduction to OS Forensics
Windows Forensics
= Collecting Volatile Information
o Volatile Information
e System Time
e Logged-On Users
» PsLoggedOn Tool
» net sessions Command
» LogonSessions Tool
e Open Files
» net file Command
» PsFile Utility
» Openfiles Command
e Network Information
e Network Connections
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Process Information
Process-to-Port Mapping
Process Memory
Network Status

Print spool files

Other Important Information

= Collecting Non-Volatile Information

©)

Non-Volatile Information

Examine File Systems
Registry Settings
Microsoft Security ID
Event Logs

ESE Database File
Connected Devices
Slack Space

Virtual Memory

Exam 312-49

Swap Space, hibernation, and Page Files

Windows Search Index

Collecting Hidden Partition Information

Hidden ADS Streams

» Investigating ADS Streams: StreamArmor

Other Non-Volatile Information

= Analyze the Windows thumbcaches

=  Windows Memory Analysis

@)
@)
@)
@)
@)
©)

o
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Virtual Hard Disk (VHD)

Memory Dump

EProcess Structure

Process Creation Mechanism

Parsing Memory Contents

Parsing Process Memory

Extracting the Process Image
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Collecting Process Memory

= Windows Registry Analysis

©)

(©)

©)

o

o

Inside the Registry

Registry Structure within a Hive File

The Registry as a Log File

Registry Analysis

System Information

TimeZone Information

Shares

Wireless SSIDs

Startup Locations

Importance of volume shadow copy services
System Boot

User Login

User Activity

Enumerating Autostart Registry Locations
USB Removable Storage Devices
Mounted Devices

Tracking User Activity

The UserAssist Keys

MRU Lists

Connecting to Other Systems

Analyzing Restore Point Registry Settings

Determining the Startup Locations

= Cache, Cookie, and History Analysis

o Cache, Cookie, and History Analysis: Mozilla Firefox

o Analysis Tool: MZCacheView
o Analysis Tool: MZCookiesView

o Analysis Tool: MZHistoryView

Exam 312-49

o Cache, Cookie, and History Analysis: Google Chrome

Page | 16

o Analysis Tool: ChromeCookiesView
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o Analysis Tool: ChromeCacheView
o Analysis Tool: ChromeHistoryView
o Cache, Cookie, and History Analysis: Microsoft Edge
o Analysis Tool: IECookiesView
o Analysis Tool: IECacheView
o Analysis Tool: BrowsingHistoryView
=  Windows File Analysis
o System Restore Points (Rp.log Files)
o System Restore Points (Change.log.x Files)
o Prefetch Files
o Shortcut Files
o Image Files
= Metadata Investigation
o Understanding Metadata
o Types of Metadata
o Metadata in Different File Systems
o Metadata in PDF Files
o Metadata in Word Documents
o Tool: Metashield Analyzer
= Text Based Logs
o Understanding Events
o Types of Logon Events
o Event Log File Format
o Organization of Event Records
o ELF_LOGFILE_HEADER structure
o EventLogRecord Structure
o Windows 10 Event Logs
= Other Audit Events
o Evaluating Account Management Events
o Examining System Log Entries
o Examining Application Log Entries
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= Forensic Analysis of Event Logs
o Searching with Event Viewer
o Using Event Log explorer to Examine Windows Log Files
o Windows Event Log Files Internals
= Windows Forensics Tools
Linux Forensics
= Shell Commands
® Linux Log files
= Collecting Volatile Data
= Collecting Non-Volatile Data
MAC Forensics
= Introduction to MAC Forensics
= MAC Forensics Data
= MAC Log Files
= MAC Directories
= MAC Forensics Tools
Back to TOC
Module 07: Network Forensics
= Introduction to Network Forensics
o Network Forensics
o Postmortem and Real-Time Analysis
o Network Vulnerabilities
o Network Attacks
o Where to Look for Evidence
= Fundamental Logging Concepts
o Log Files as Evidence
o Laws and Regulations
o Legality of using Logs
o Records of Regularly Conducted Activity as Evidence
= Event Correlation Concepts
o Event Correlation
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o Types of Event Correlation
o Prerequisites of Event Correlation
o Event Correlation Approaches
= Network Forensic Readiness
o Ensuring Log File Accuracy
= Log Everything
= Keeping Time
» Why Synchronize Computer Times?
» What is Network Time Protocol (NTP)?
= Use Multiple Sensors
= Avoid Missing Logs
o Implement Log Management
= Functions of Log Management Infrastructure
= Challenges in Log Management
= Meeting the Challenges in Log Management
= (Centralized Logging
= Syslog
= |IS Centralized Binary Logging
o Ensure System’s Integrity
o Control Access to Logs
= Network Forensics Steps
o Ensure Log File Authenticity
= Use Signatures, Encryption, and Checksums
o Work with Copies
o Maintain Chain of Custody
o Condensing Log File
o Analyze Logs
= Network Forensics Analysis Mechanism
» Log Capturing and Analysis Tools: GFl EventsManager
» Log Capturing and Analysis Tools: EventLog Analyzer
» Log Capturing and Analysis Tools
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= Analyzing Router Logs
= Evidence Gathering from ARP Table
= Analyzing Router Logs (Cont’d)
= Analyzing Router Logs: Cisco
= Analyzing Router Logs: Juniper
= Analyzing Firewall Logs
= Analyzing Firewall Logs: Cisco
= Analyzing Firewall Logs: Checkpoint
= Analyzing IDS Logs
= Analyzing IDS Logs: Juniper
= Analyzing IDS Logs: Checkpoint
= Analyzing Honeypot Logs
= DHCP Logging
» Sample DHCP Audit Log File
» Evidence Gathering at the Data-Link Layer: DHCP Database
= ODBC Logging

= Network Traffic Investigation

Page | 20

o

o

Why Investigate Network Traffic?
Evidence Gathering via Sniffing
= Sniffing Tool: Wireshark
= Display Filters in Wireshark
= Additional Wireshark Filters
= Sniffing Tool: SteelCentral Packet Analyzer
= Sniffing Tool: Tcpdump/Windump
= Packet Sniffing Tool: Capsa Network Analyzer
= Network Packet Analyzer: OmniPeek Network Analyzer
= Network Packet Analyzer: Observer
Network Packet Analyzer: Capsa Portable Network Analyzer
= TCP/IP Packet Crafter: Colasoft Packet Builder
= Network Packet Analyzer: RSA NetWitness Investigator
= Additional Sniffing Tools
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o Gathering Evidence from an IDS
= Documenting the Evidence

= Evidence Reconstruction

Back to TOC

Module 08: Investigating Web Attacks

Introduction to Web Application Forensics

o Introduction to Web Application Forensics
o Web Application Architecture

o Challenges in Web Application Forensics
Web Attack Investigation

o Indications of a Web Attack

o Web Application Threats - 1

o Web Application Threats - 2

o Investigating a Web Attack

o Investigating Web Attacks in Windows-Based Servers

Investigating Web Server Logs

o Internet Information Services (IIS) Logs
e IS Web Server Architecture
e |ISLogs
e |nvestigating IIS Logs
e Maintaining Credible IIS Log Files
e Investigating IIS Logs: Best Practices
e UTCTime

o Investigating Apache Logs
e Apache Web Server Architecture
e Apache Web Server Logs
e Investigating Apache Logs

o Investigating Cross-Site Scripting (XSS)

o Investigating XSS: Using Regex to Search XSS Strings

o Investigating SQL Injection Attacks

Page | 21
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o Pen-Testing CSRF Validation Fields

o Investigating Code Injection Attack

o Investigating Cookie Poisoning Attack

=  Web Attack Detection Tools

o Web Log Viewers

= Tools for Locating IP Address

o |IP Address Locating Tools
=  WHOIS Lookup Tools
=  WHOIS Lookup Tools

Back to TOC

Module 09: Database Forensics

= Database Forensics and Its Importance

=  MSSQL Forensics

o Data Storage in SQL Server

o Database Evidence Repositories

o Collecting Volatile Database Data

Collecting Primary Data File and Active Transaction Logs Using SQLCMD
Collecting Primary Data File & Transaction Logs

Collecting Active Transaction Logs Using SQL Server Management Studio
Collecting Database Plan Cache

Collecting Windows Logs

Collecting SQL Server Trace Files

Collecting SQL Server Error Logs

Database Forensics Using SQL Server Management Studio

Database Forensics Using ApexSQL DBA

=  MySQL Forensics

o Internal Architecture of MySQL

Structure of the Data Directory

o MySQL Forensics

Page | 22

Viewing the Information Schema
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e MySQL Utility Programs For Forensic Analysis
e Common Scenario for Reference

= MySQL Forensics for WordPress Website Database: Scenario 1
Collect the Evidences

Examine the Log Files

Analyze the General Log

Take a Backup of the Database

Create an Evidence Database

Select the Database

View the Tables in the Database

View the Users in the Database

View Columns in the Table

Collect the Posts Made by the User

YV V.V V V V V V V V V

Examine the Posts Made by the User

=  MySQL Forensics for WordPress Website Database: Scenario 2
» Collect the Database and all the Logs

Examine the .frm Files

Examine the Binary Logs

Retrieve the Deleted User Account

YV V V V

ibdatal in Data Directory
Back to TOC

Module 10: Cloud Forensics
= |ntroduction to Cloud Computing
o Types of Cloud Computing Services
o Separation of Responsibilities in Cloud
o Cloud Deployment Models
o Cloud Computing Threats
o Cloud Computing Attacks
= Cloud Forensics

O Usage of Cloud Foreniscs
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©)

o

Cloud Crimes

e Case Study: Cloud as a Subject

e Case Study: Cloud as the Object

e (Case Study: Cloud as a Tool

Cloud Forensics: Stakeholders and their Roles
Cloud Forensics Challenges

e Architecture and Identification

e Data Collection

o Legal

e Analysis

e Cloud Forensics Challenges

Investigating Cloud Storage Services
Investigating Dropbox Cloud Storage Service

e Artifacts Left by Dropbox Web Portal

e Artifacts Left by Dropbox Client on Windows
Investigating Google Drive Cloud Storage Service
e Artifacts Left by Google Drive Web Portal

e Artifacts Left by Google Drive Client on Windows
Cloud Forensics Tools: UFED Cloud Analyzer

Back to TOC

Module 11: Malware Forensics

= |ntroduction to Malware

(0]

(0]

(0]

Different Ways a Malware can Get into a System
Common Techniques Attackers Use to Distribute Malware on the Web

Components of Malware

= |ntroduction to Malware Forensics

@)
@)
@)

o
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Why Analyze Malware

Identifying and Extracting Malware

Prominence of Setting up a Controlled Malware Analysis Lab
Preparing Testbed for Malware Analysis
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o Supporting Tools for Malware Analysis

o General Rules for Malware Analysis

o Documentation Before Analysis

o Types of Malware Analysis

e Malware Analysis: Static

>
>
>
>
>
>
>
>
>
>

Static Malware Analysis: File Fingerprinting
Online Malware Testing: VirusTotal

Online Malware Analysis Services

Local and Online Malware Scanning

Performing Strings Search

Identifying Packing/Obfuscation Methods

Finding the Portable Executables (PE) Information
Identifying File Dependencies

Malware Disassembly

Malware Analysis Tool: IDA Pro

e Malware Analysis: Dynamic

>
>
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Installation Monitor

Process Monitor

=  Process Monitoring Tool: What's Running

=  Process Monitoring Tools

Files and Folder Monitor

= Files and Folder Integrity Checkers: FastSum and WinMD5
= Files and Folder Integrity Checkers

Registry Monitor

= Registry Entry Monitoring Tool: RegScanner

= Registry Entry Monitoring Tools

Network Activity Monitor

= Detecting Trojans and Worms with Capsa Network Analyzer
Port Monitor

=  Port Monitoring Tools: TCPView and CurrPorts

DNS Monitoring/Resolution
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» API Calls Monitor

» Device Drivers Monitor
= Device Drivers Monitoring Tool: DriverView
= Device Drivers Monitoring Tools

» Startup Programs Monitor
=  Windows 10 Startup Registry Entries
= Startup Programs Monitoring Tool: Security AutoRun
= Startup Programs Monitoring Tools

» Windows Services Monitor
= Windows Service Manager (SrvMan)
=  Windows Services Monitoring Tools

e Analysis of Malicious Documents

e Malware Analysis Challenges
Back to TOC

Module 12: Investigating Email Crimes
= Email System
o Email Clients
o Email Server
o SMTP Server
o POP3 Server
o IMAP Server
o Importance of Electronic Records Management

= Email Crimes (Email Spamming, Mail Bombing/Mail Storm, Phishing, Email Spoofing, Crime
via Chat Room, Identity Fraud/Chain Letter)

o Crime Via Chat Room
= Email Message
o Sample of Email Header
o List of Common Headers
o List of Common X-Headers
= Steps to Investigate Email Crimes and Violation

o Obtain a Search Warrant and Seize the Computer and Email Account
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Examine E-mail Messages

Copy and Print the E-mail Message

Viewing Email Headers in Microsoft Outlook
Viewing Email Headers in Microsoft Outlook.com
Viewing Email Headers in AOL

Viewing Email Headers in Apple Mail
Viewing Email Headers in Gmail

Viewing Headers in Yahoo Mail

Received Headers

Analyzing Email Headers

Examining Additional Files (.pst or .ost files)
Checking the E-mail Validity

Examine the Originating IP Address

Trace the E-mail Origin

Validating Header Information

Tracing Back Web-based E-mail

Acquire Email Archives

Email Archives

Content of Email Archives
Local Archive

Server Storage Archive

Forensic Acquisition of Email Archive

Recover Deleted Emails

Deleted Email Recovery

Examining Email Logs

Examining Linux E-mail Server Logs
Examining Microsoft Exchange E-mail Server Logs

Examining Novel Group-wise E-mail Server Logs

=  Email Forensics Tools

o Recover My Email
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©)

©)

MailXaminer

Email Forensics Tools

= Laws and Acts against Email Crimes

(©)

U.S. Laws Against Email Crime: CAN-SPAM Act

Back to TOC

Module 13: Mobile Phone Forensics

=  Mobile Device Forensics

©)

Page | 28

Why Mobile Forensics?

Top Threats Targeting Mobile Devices

Mobile Hardware and Forensics

Mobile OS and Forensics

e Architectural Layers of Mobile Device Environment
e Android Architecture Stack

e Android Boot Process

e iOS Architecture

e iOS Boot Process

e Normal and DFU Mode Booting

e Booting iPhone in DFU Mode

e Mobile Storage and Evidence Locations
What Should You Do Before the Investigation?
e Build a Forensics Workstation

e Build the Investigation Team

e Review Policies and Laws

e Notify Decision Makers and Acquire Authorization
e Risk Assessment

e Build a Mobile forensics Toolkit

e Mobile Phone Evidence Analysis

Mobile Forensics Process

e Collecting the Evidence

e Document the Scene
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e Document the Evidence
e Evidence Preservation
e Set of Rules for Switching ON/OFF Mobile Phone
e Mobile Phone Signal Containment
e Packing, Transporting, and Storing the Evidence
e Forensics Imaging
» Forensics Imaging of Android Device Using FTK Imager
» Creating Disk Image of an iPhone Using SSH
e Phone Locking
» Bypassing Android Phone Lock Password Using ADB
» iPhone Passcodes
» Bypassing the iPhone Passcode Using IExplorer
e Enabling USB Debugging
e Platform Security Removal Techniques: Jailbreaking/Rooting
e Mobile Evidence Acquisition
» Data Acquisition Methods
e Cellular Network
Components of Cellular Network
Different Cellular Networks
Cell Site Analysis: Analyzing Service Provider Data

CDR Contents

YV V YV V V

Sample CDR Log File
e Subscriber Identity Module (SIM)

» SIM File System
» Data Stored in a Subscriber Identity Module
» Integrated Circuit Card Identification (ICCID)
» International Mobile Equipment Identifier (IMEI)
» Electronic Serial Number (ESN)
» SIM Cloning
» SIM Data Acquisition Tools
» SIM Forensic Analysis Tools
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e Logical Acquisition
» Android Logical Acquisition Using MOBILedit
» Additional Logical Acquisition Tools
e Physical Acquisition
» Physical Acquisition Using Oxygen Forensic Suite
e File System Acquisition
» File System Acquisition Using Oxygen Forensic Suite
e File Carving
» File Carving Using Forensic Explorer
» iPhone File Carving Using Scalpel Tool
» File Carving Tools
e SQlite Database Extraction
» Forensics Analysis of SQLite Database Using Andriller
» SQLite Database Browsing Tools: Oxygen Forensics SQLite Viewer
» SQLite Database Browsing Tools
e Android Forensics Analysis
e iPhone Data Extraction
» iPhone Data Acquisition Tools
» iPhone Forensics Analysis Using the Oxygen Forensics Suite
e Examination and Analysis
e Generating Investigation Report
e Mobile Forensics Report Template
» Sample Mobile Forensics Analysis Worksheet

» Cellebrite UFED Touch Sample Mobile Forensic Report Snapshot
Back to TOC
Module 14: Forensics Report Writing and Presentation

= Writing Investigation Reports
o Forensic Investigation Report
o Important Aspects of a Good Report

o Forensic Investigation Report Template
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o Report Classification

o Guidelines for Writing a Report

o Other Guidelines for Writing a Report

= Expert Witness Testimony

Exam 312-49

o What is an Expert Witness?
o Roles of an Expert Witness
o Technical Witness Vs. Expert Witness
o Daubert Standard
o Frye Standard
o What Makes a Good Expert Witness?
o Importance of Curriculum Vitae
o Professional Code of Conduct for an Expert Witness
o Preparing for a Testimony
e Testifying in the Court
e General Order of Trial Proceedings
e General Ethics While Testifying
e Importance of Graphics in a Testimony
e Helping your Attorney
e Avoiding Testimony Issues
e Testifying during Direct Examination
e Testifying during Cross- Examination
e Testifying during Cross- Examination: Best Practices
o Deposition
e Guidelines to Testify at a Deposition
o Dealing with Media
Back to TOC
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